Activities not sharing to Strava and Training Peaks
Incident Report for The Sufferfest

We've had some periodic issues with sharing to other sites and services. Every few weeks the queue that processes them would just stop taking in new requests and the outstanding requests wouldn't get processed. Deleting the queue or restarting the server usually fixed the issue for a while. I realized that the connections to the queue were very high when it would stop working but didn't understand why the connection count was constantly increasing. Finally, this evening I rewrote the code that queues the activities to be shared so it correctly closes the connection after adding to the queue so we shouldn't run into this issue again. But we'll continue to monitor it. -Reid

Posted 4 months ago. Jun 07, 2017 - 15:46 AEST

Resolved
Activities are being shared to TrainingPeaks, email, and Strava correctly now. If your activity hasn't shown up yet, please share it again from the Passport tab in the app.
Posted 4 months ago. Jun 07, 2017 - 13:15 AEST
Identified
Activity shares are processing now. The server is going through the queue and should be done in 10-20 minutes. If you don't see your activity on Strava or TrainingPeaks in that time, please try sharing it again from within the app on the Passport tab.
Posted 4 months ago. Jun 07, 2017 - 10:05 AEST
Investigating
Activities aren't sharing to other services at the moment. Seems to be happening across all types (email, strava, TrainingPeaks).
Posted 4 months ago. Jun 07, 2017 - 09:12 AEST